So you want to install eclipse on Mavericks?

So you want to install Eclipse on your new Mac? Getting back into JAVA programming? Get ready for this error:

Error: Eclipse requires Java 7

For us Mac users, this experience can be pretty jarring –¬†what, something didn’t install on the first try and work right away? Another sign of a company deteriorating without Steve Jobs…

The problem is Eclipse requires Java 7, but Mac OSX requires Java 6. If you try to download Java 7 in Chrome, you’ll run against a pleasant message along these lines:

Error Java 7 doesn't work with ChromeAgain, totally useless. Why make your web browsing not work to code?

Alas, if you Google around, you’ll find complex solutions that involve using sudo and the command line to manually remove 1.6 and symlink 1.7. Basically, you can smash your head into a wall for hours just to get programming.

Why go through all the trouble when there’s an easy solution?

Download Google’s version of the SDK. The version of the Eclipse included¬†there works on your Mac.

Your welcome :).

Leave your thoughts